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Required programs 
 

• Daz Studio 4.5+ 
• Poser 2012+ (Some morphs ONLY works in Poser. So to convert those, the morphs must be applied 

in Poser and exported as a .CR2 file and imported into Daz Studio) 
• The Gen4/Gen3 figure. I.e. V4/M4 incl. the morphs++ packages. 
• Genesis Generation X 

http://www.daz3d.com/genesis-generation-x 
• V4 and M4 Shapes for Genesis 

http://www.daz3d.com/v4-and-m4-shapes-for-genesis 
• GenX AddOn Gen3 for V3 and M3 

http://www.daz3d.com/genx-addon-gen3-for-v3-and-m3 
• GenX AddOn Gen3 for A3 and H3 

http://www.daz3d.com/genx-addon-gen3-for-a3-and-h3 
• GenX AddOn Gen3 for S3 D3 and F3 

http://www.daz3d.com/genx-addon-gen3-for-s3-d3-and-f3 
• DSF Toolbox 

http://www.daz3d.com/dsf-toolbox 
• Text Editor (Notepad etc.) 

Useful reading 
 

• DSON File Format Specification 
http://docs.daz3d.com/doku.php/public/dson_spec/object_definitions/start 

 

GenX settings 
 

 

a) Screenshot of the GenX settings used. 

If you don’t plan on manually editing the morphs later using a text editor, you can turn on the “Compress 
generated files” too.  

http://www.daz3d.com/genesis-generation-x
http://www.daz3d.com/v4-and-m4-shapes-for-genesis
http://www.daz3d.com/genx-addon-gen3-for-v3-and-m3
http://www.daz3d.com/genx-addon-gen3-for-a3-and-h3
http://www.daz3d.com/genx-addon-gen3-for-s3-d3-and-f3
http://www.daz3d.com/dsf-toolbox
http://docs.daz3d.com/doku.php/public/dson_spec/object_definitions/start
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Creating a single morph dial from multiple morphs 

Combining all morphs into an .OBJ file 
 

1. Load Daz Studio 
2. Clear the Scene. 
3. Load the Gen4 (M4/V4) figure. 
4. Zero figure pose. (Important, or you get a lot of useless morphs transferred) 
5. INJect the morphs you want to transfer. 
6. Export the figure as an .OBJ file. (File -> Export) – You can uncheck everything except "Groups". 
7. Clear the Scene. 
8. Load the Gen4 (M4/V4) figure. 
9. Zero figure pose. (Important, or you get a lot of useless morphs transferred) 
10. Select Figure->Morph Loader Pro and import the .OBJ file you exported in Step #6. 
11. Export the figure as a .CR2 file. (File -> Export) 
12. Clear the Scene. 
13. Open the “GenX” Tab. 
14. Load the .CR2 figure you exported in Step #11, into GenX. 
15. Unfold the BODY part, look for a morph named “Morphloader Pro” and check the checkbook for 

that one. 
16. Set the type to “Selected morphs”. 
17. Click the “Transfer” button. 
18. Fill in the “Identifier” field (I usually use the first letters in the creators name.)  
19. Fill in the “Name” field with the name of the morph. 
20. Click the “Accept” button. 

 

b) Example of filled “Transfer” dialog box. 
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Morphs created using Morphs++ or Creature pack 
 

21. Load Daz Studio 
22. Open the “GenX” Tab. 
23. Load the Gen4 (M4/V4) figure into GenX. 
24. Apply the appropriate Morphs++ package. 
25. Apply the appropriate Creatures morph package if needed. 
26. Apply the morph package you want transfer. 
27. Set the type to “Create single morph”. 
28. Click the “Select” button and choose “Transfer: On for All Non-Zero Values”. 
29. Click the “Transfer” button. 
30. Fill in the “Identifier” field. (NOTE: When using the type “Create single morph”, you will have to fill 

in the COMPLETE filename in the “Identifier” field!)  
31. Fill in the “Name” field with the name of the morph. 
32. Click the “Accept” button. 

 

 

c) Example of filled “Transfer” dialog box. Notice that FULL name have been entered as identifier. 
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Transferring multiple morphs 

The “Auto convert” method 
 

1. Load Daz Studio 
2. Load the Gen4 figure. 
3. Zero figure pose. 
4. INJect the morphs you want to transfer. 
5. Turn ALL the dials to max, for the morphs you want to transfer. (Ignore that the figure will look 

screwed up.) 
6. Export the figure as a .CR2 file. 
7. Clear the scene. 
8. Open the “GenX” Tab. 
9. Load the .CR2 figure into GenX. 
10. Set the type to “Selected morphs” or “Create single morph”. 
11. Click the “Select” button and choose “Transfer: On for All Non-Zero Values”. 
12. Click the “Transfer” button. 
13. Fill in the “Identifier” field (I usually use the first letters in the creators name.)  
14. Fill in the “Name” field with the name of the morph. 
15. Click the “Accept” button. 
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Selecting morphs manually 
 
This method can be useful in situations you only want to transfer the Head morph, but the INJ file injects 
both Head and Body morphs or in situations where you need to exclude certain parts of the morph. 
 

1. Load Daz Studio 
2. Open the “GenX” Tab. 
3. Load the Gen4 figure into GenX. 
4. Apply the morph package you want converted. 
5. Unfold the bodyparts you want to select. Usually you can find most morphs located in the BODY 

section. 
6. Check each morph you want to transfer. 
7. Repeat step 5-6 until you have selected it all. 
16. Set the type to “Selected morphs” or “Create single morph”, depending on what you are 

transferring. 
8. Click the “Transfer” button. 
9. Fill in the “Identifier” field (I usually use the first letters in the creators name.)  
10. Fill in the “Name” field with the name of the morph. 
11. Click the “Accept” button. 

 

Known problems converting using GenX 
 

• Problem: Gen4 morphs that hides the finger and toe nails doesn’t transfer well to Genesis. 
Solution: Use the “Selecting morphs manually” method and deselect all the morphs on the last digit 
of fingers and toes. 
 

• Problem: With some morphs the eyes and teeth isn’t positioned correct, but stays in the default 
position. 
Solution: Use the “Combining all morphs into an .OBJ file” method, and everything will be 
transferred. 
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Transferring Gen4 morphs to Genesis using only standard DS functionality 
 
Note: Morphs converted using this method will usually not look as good as those converted using GenX. 

With some slight modifications this method could also be used for converting morphs to Genesis2 format.  

1) Load the Gen4 (V4/M4 etc.) figure 
2) Zero Pose (Edit->Figure->Zero->Zero Figure Pose) 
3) Inject desired Character face/body Injection 
4) Export the Gen4 figure with morph(s) as OBJ (File->Export - Save as type: Wavefront Object (*.obj)) 
5) Delete the Gen4 (File->New) 
6) Load the Gen4 figure. 
7) Convert the Gen4 to TriAx Weight Mapping (Edit->Figure->Rigging->Convert Figure to Weight 

Mapping - Select TriAx Weight Mapping) 
8) Apply the morph to the Gen4 figure (Edit->Figure->Morphloader Pro - Choose Morphs Files. Select 

the .OBJ file created in step 4) 
9) Dial in Character morphs (The ones that was injected in step 3) 
10) Load Genesis figure. 
11) Dial in Genesis corresponding shape (i.e. V4/M4) 
12) Transfer morphs from Gen4 figure to Genesis. (Edit->Figure->Transfer Utility) 
13) Source - Scene Item: Select the Gen4 figure 
14) Source - Item shape: Default 
15) Target - Scene Item: Select the Genesis figure 
16) Target - Item shape: Clone (Select the matching Gen4 figure) 
17) Click "Show options" and in General Options uncheck everything except "Weight Maps" and 

"Morph Targets" 
18) Then click "Morph Targets", and in the "Extended Options" check "Source Morphs" and uncheck 

"Projection Template Morphs". Also uncheck the "Fit To Source Figure" 
19) When complete, you can remove the Gen4 figure from the scene. 
20) Select the Genesis figure and dial in the new imported morph. 
21) Dial in any other needed morphs to make the character look right (V4/M4 etc.) 
22) If you are satisfied with the result, you can save the morphs. (File->Save As->Support Asset->Morph 

Asset) 
23) Check only the new morph and any other required morphs (the ones you dialed in in step 14-15) 
24) Close and reload Daz Studio, and the new Morphs are now ready to be used on the Genesis figure.  
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Cleaning up the morphs 

Using DFS-Tools 
 
With DSF-Tools you can easily clean up various parts of the morph, such as the names and limits. 

 

The editing tools for the channel parameters and the asset info have the same structure. They can be used 
with single files or to modify several files at once. They have the following buttons:  

• Load DSF: Load a single DSF file for editing.  
• Save DSF: Saves a previously loaded single DSF file.  
• Set in DSF: Applies modifications to several DSF files at once.  
• Reset: Resets all parameters. If a single file was loaded, it is unloaded.  

The checkboxes in the leftmost column (and for Maximum) indicate, whether a particular parameter is used 
or not. For the other checkboxes, the undetermined state means that a parameter is not used.  

• Most parameters are text only and may be blank.  
• Don't use the quotation mark sign " in any text fields or you will destroy the file formatting. 
• When using drag'n'drop, dropping a single file will load it in the editor, while dropping several files 

will modify all of them (even if there is nothing to modify).  
• The editors load and save the complete DSF file. Don't switch between editors while editing the 

same file or one editor will overwrite the changes of the other.  
• The Channel editor is also used for morph channel templates and details of created morphs.  
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Editing a Single File 
 
When you load a single file for editing with the Load DSF button, the editor indicates which parameters are 
present in the DSF file and which values they have. You can modify any value and add any missing 
parameter. However, it's not possible to remove a parameter. Marking an existing parameter as unused 
will only leave it unmodified. The changes are applied when you save the file with the Save DSF button.  

 

Modifying Several Files 
 
Mark any parameter you want to change as a used parameter and enter the desired value. Then, use the 
Set in DSF button or drag'n'drop to apply these modifications to any number of files.  

 

Channel Editor 
 
The Channel editor allows you to change the values for all parameters in a morph or other controller DSF 
file. Most of these values can be changed also inside of DAZ Studio, but only for the current scene. The 
meaning and correct values for most parameters should be straightforward.  

• Value, Minimum, Maximum, and Sensitivity must be real numbers.  
• Region depends on the target figure. The drop down list contains the regions for Genesis. 
• Group should start with a slash sign /. Further slashes separate sub-groups.  
• I have no idea, where Label and Description are shown or used in DAZ Studio.  
• Large icon and Small icon should be PNG images with a path relative to data.  
• Large icon should be 147x185 with appropriate transparency to not overlap with the slider. 
• Small icon should be 39x39 with appropriate transparency to not overlap with the slider. 
• Small icon seems to be ignored if there is no Large icon.  
• Click on the Color gradient buttons to select a color. Click on None to reset the colors; when no 

colors are set, the user defined color without gradient is used instead.  
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Asset Info Editor  
 

The Asset Info editor allows you to change the values for the info data that may be included in any DSF file.  

• All fields are text and may have any value.  
• File, ID, and type can't be changed, they are for information only.  
• Click on Defaults to set author, email, website, and revision to the values from Options. 
• Click on Now to set the current time and date in the Modified field.  

 

Using a text editor 
 
You can also do some more advanced cleanup and morph combining using a text editor, but this requires 
some knowledge of the DSF format. (See the “Useful reading” chapter for some links) 
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